模拟器编译报错 Undefined symbols for architecture x86_64
iiiGlare 发布于2015-09 浏览:18950 回复:18
0
收藏


我在添加了SDK后编译,真机是正常的,模拟器却报了 x86_64 的错误,然而我在 architecture 中并未添加该字段。


请问下到底发生了什么。


错误日志如下:


Undefined symbols for architecture x86_64:

  "GetLicense(char const*, char const*, char const*)", referenced from:

      -[BDVROfflineEngine licenseFromServer] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "VerifyLicense(char const*, char const*, unsigned int&)", referenced from:

      -[BDVROfflineEngine verfiyLicense] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrBuildSlot", referenced from:

      -[BDVROfflineEngine initOfflineEngine] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

      -[BDVROfflineEngine flushSlot:] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrExit", referenced from:

      -[BDVROfflineEngine unInitOfflineEngine] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrFeedAudioData", referenced from:

      -[BDVROfflineEngine feedAudio:] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrGetJSONResult", referenced from:

      -[BDVROfflineEngine feedAudio:] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrInitial", referenced from:

      -[BDVROfflineEngine initOfflineEngine] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrSetParam", referenced from:

      -[BDVROfflineEngine setParameter] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrSetSlot", referenced from:

      -[BDVROfflineEngine initSlot] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrStartRecognition", referenced from:

      -[BDVROfflineEngine setRecoginitionProperty] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

  "_bdeasrStopRecognition", referenced from:

      -[BDVROfflineEngine feedAudio:] in libBDVoiceRecognitionClient.a(BDVROfflineEngine.o)

ld: symbol(s) not found for architecture x86_64

clang: error: linker command failed with exit code 1 (use -v to see invocation)


收藏
点赞
0
个赞
共18条回复 最后由用户已被禁言回复于2022-04
#21chenxiaoyu3回复于2017-09

wangdazhou258:

平时搞开发不可能每次都用真机运行吧,使用一个SDK导致模拟器不能用不划算

回复wangdazhou258:请使用真机测试,谢谢!

0
#20wangdazhou258回复于2017-09

平时搞开发不可能每次都用真机运行吧,使用一个SDK导致模拟器不能用不划算

0
#19fang4096回复于2016-11

没有计划支持模拟器。新版本对模拟器进行了屏蔽,也只是解决了编译问题。

0
#18畜牧展览会回复于2016-10

fang4096:

改版本SDK不支持模拟器。

回复fang4096:什么时候能解决对模拟器的支持问题

0
#17fang4096回复于2016-07

改版本SDK不支持模拟器。

0
#16许金秧回复于2016-07

我用真机也会出现这个问题,官方快解决问题啊,

0
#15fang4096回复于2016-05

SDK不支持模拟器,请使用真机测试。

0
#13c5812回复于2016-05

在真机是否也有此问题呢

0
#12cqw04191993回复于2016-04

同问?有人有解决方法吗?

0
#11夜半蟋蟀声回复于2015-12

搞了个SDK,也没官方的人来回复开发者的问题。。。果然是大公司,BAT马上就成AT了

0
#10ascode回复于2015-12

问题同上,在群里面去问,没一个人理会的

0
#9伟199111回复于2015-12

同问

0
#7空中之王的海角回复于2015-12

有人解决了这个问题没?同求

0
#6W_WTYN回复于2015-11

有大神解决了没啊,为何SDK一直报错呢

0
#5风止雨息回复于2015-11

同,顶!

0
#4wa...n@cric.com回复于2015-11

同样的问题!!    


0
#3adewang2010回复于2015-10

同样的问题。。。 和xcdoe7.0有关吗?

0
#2shww_web回复于2015-10

同样的问题

0
TOP
切换版块