语音识别android 报错
Id65ef6 发布于2017-12 浏览:2469 回复:15
0
收藏

2-19 11:33:36.578: W/System.err(14626): Caused by: java.lang.ClassNotFoundException: Didn't find class "com.baidu.android.common.util.DeviceId" on path: DexPathList[[zip file "/data/app/com.std.speak-1/base.apk"],nativeLibraryDirectories=[/data/app/com.std.speak-1/lib/arm, /data/app/com.std.speak-1/base.apk!/lib/armeabi-v7a, /vendor/lib, /system/lib]]
12-19 11:33:36.578: W/System.err(14626): at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56)
12-19 11:33:36.578: W/System.err(14626): at java.lang.ClassLoader.loadClass(ClassLoader.java:511)
12-19 11:33:36.579: W/System.err(14626): at java.lang.ClassLoader.loadClass(ClassLoader.java:469)
12-19 11:33:36.579: W/System.err(14626): ... 15 more
12-19 11:33:36.579: W/System.err(14626): Suppressed: java.lang.ClassNotFoundException: com.baidu.android.common.util.DeviceId
12-19 11:33:36.579: W/System.err(14626): at java.lang.Class.classForName(Native Method)
12-19 11:33:36.579: W/System.err(14626): at java.lang.BootClassLoader.findClass(ClassLoader.java:781)
12-19 11:33:36.579: W/System.err(14626): at java.lang.BootClassLoader.loadClass(ClassLoader.java:841)
12-19 11:33:36.579: W/System.err(14626): at java.lang.ClassLoader.loadClass(ClassLoader.java:504)
12-19 11:33:36.579: W/System.err(14626): ... 16 more
12-19 11:33:36.579: W/System.err(14626): Caused by: java.lang.NoClassDefFoundError: Class not found using the boot class loader; no stack trace available

收藏
点赞
0
个赞
共15条回复 最后由用户已被禁言回复于2022-04
#16我是CT派回复于2018-05

非常感谢!

 

0
#15卡农LLLL回复于2018-05

https://pan.baidu.com/s/1MrBhzhS75AxrsYDZKbcKFA

 

我传了一个jar包到云盘里面.你们下了试试.

0
#14air543447715回复于2018-05

这个问题怎么解决呢,目前开发出现了问题

0
#13我是CT派回复于2018-04

没找到啊。。这个问题解决不了,日志都没法用呀

0
#12卡农LLLL回复于2018-01
#11 Triumph_倾城回复
@卡农LLLL     有这个jar包的地址能提供一下吗?感谢

https://github.com/dueros/dcs-sdk-java

我在这个里面找到的.

0
#11Triumph_倾城回复于2018-01

@卡农LLLL     有这个jar包的地址能提供一下吗?感谢

0
#10卡农LLLL回复于2018-01

反正我这里是这样的..

0
#9静心之王回复于2018-01

jar的问题?

0
#8哈哈的我的哈哈回复于2018-01

这个问题不影响开发,不用管就是了

0
#7卡农LLLL回复于2018-01

最近百度系更新的包吧...我不是很清楚..但我找到了这个jar包引入进去就对了.

0
#6卡农LLLL回复于2018-01

这个类是galaxy-lite-2.0.0.jar下的一个

0
#5thearyong回复于2018-01

同样的问题,有解决的朋友不

0
#4哈哈的我的哈哈回复于2017-12

我也遇到一样的问题,怎么解决的

0
#3longlongpm回复于2017-12

jar包里有错误com.baidu.android.common.util.DeviceId=>com.baidu.android.speech.utils.DeviceId,应该没影响

0
#2用户已被禁言回复于2017-12

您好,感谢您使用百度AI社区,如果有志同道合的小伙伴遇到过相似问题并解决了会给您答复,同时我们也内部再跟进您这个问题,会尽快给您具体答复

0
TOP
切换版块