Android 6.0 WRITE_SETTINGS 权限问题
天空之猎手 发布于2016-03 浏览:3372 回复:4
0
收藏

百度语音在获取Device id时要用到permission android.permission.WRITE_SETTINGS权限

Android 6.0 即使调用

Intent intent = new Intent(android.provider.Settings.ACTION_MANAGE_WRITE_SETTINGS);
intent.setData(Uri.parse("package:" + getPackageName()));
startActivityForResult(intent, REQUEST_WRITE_SETTING);

仍然无效

收藏
点赞
0
个赞
共4条回复 最后由用户已被禁言回复于2022-04
#17用户已被禁言回复于2022-04

https://quanmin.baidu.com/wise/growth/querypage?keyword=%E7%BC%85%E7%94%B8%E9%BE%99%E6%BA%90%E8%B5%8C%E5%9C%BA%E7%BD%91%E6%8A%95%E5%B9%B3%E5%8F%B0%E7%BD%91%E5%9D%80%E7%9B%B4%E8%90%A5%E5%BC%80%E6%88%B7%3AB2024%C2%B7CN%E5%8D%97%E5%AE%81%E6%96%B0%E9%97%BB%EF%BD%8A%EF%BD%85%EF%BD%82 http://www.huanqiu.cc/search/index.html?keyword=%E8%80%81%E8%A1%97%E6%96%B0%E7%99%BE%E8%83%9C%E9%9B%86%E5%9B%A2%E8%A6%81%E6%80%8E%E4%B9%88%E6%B3%A8%E5%86%8C%E3%80%90B2024%C2%B7CN%E3%80%91%E5%8D%97%E6%98%8C%E7%BD%91%E9%80%9A%EF%BD%9E%EF%BC%94%EF%BD%97 http://xy.iqiyi.com/so/q_%E8%B5%8C%E5%9C%BA%E5%B9%B3%E5%8F%B0%E5%9C%A8%E7%BA%BF%2C%E7%BD%91%E4%B8%8A%E8%B5%8C%E5%9C%BA%E5%A8%B1%E4%B9%90%E7%BD%91%E7%AB%99%2C%E7%8E%B0%E9%87%91%E7%9C%9F%E4%BA%BA%E8%B5%8C%E5%9C%BA%E5%BE%AE%E4%BF%A1%E5%BC%80%E6%88%B7%E7%94%B5%E8%AF%9D%E7%BD%91%E5%9D%80B2024.%EF%BC%A3N%E6%B3%B8%E5%B7%9E%E9%98%B2%E7%96%AB%EF%BD%8B%EF%BC%B8%EF%BD%85?source=hot http://search.114chn.com/SearchResult.aspx?key=%E7%BC%85%E7%94%B8%E5%B0%8F%E5%8B%90%E6%8B%89%E9%BE%99%E6%BA%90%E5%9B%BD%E9%99%85%E3%80%90%E5%AE%98%E7%BD%91%E2%86%92B2024%C2%B7CN%E3%80%91%E5%A4%A7%E5%BA%86%E4%BA%BA%E6%89%8D%E7%BD%91%EF%BC%AD&type=1 http://www.kingdee.com/?s=%E7%BC%85%E7%94%B8%E7%BB%B4%E5%8A%A0%E6%96%AF%E8%80%81%E6%9D%BF%E6%9D%B0%E5%93%A5%E3%80%90%E5%AE%98%E7%BD%91%E2%86%92B2024.CN%E3%80%91%E5%8C%97%E6%B5%B7%E7%94%B5%E5%8F%B0%EF%BC%93%EF%BC%A2%EF%BD%9A

0
#4c5812回复于2016-10

可以参考 https://github.com/baidu/speech-samples 


配置文件如:https://github.com/baidu/speech-samples/blob/master/sdk/android/eclipse/asr%26wakeup/AndroidManifest.xml


0
#3w_xuanlong回复于2016-10

无效ctfyhome:

可以尝试将AndroidManifest.xml中的targetSdkVersion设置为<22的值

回复ctfyhome:

0
#2ctfyhome回复于2016-03

可以尝试将AndroidManifest.xml中的targetSdkVersion设置为<22的值

0
TOP
切换版块