语音合成SDKjava 报错
来个名字2333 发布于2018-06 浏览:1538 回复:6
1
收藏
语音合成通过SDK方式调用,直接按照https://ai.baidu.com/docs#/TTS-Online-Java-SDK/top 给的源代码,运行之后报错
 
错误原因是 LOGGER找不到,语音合成需要依赖的三个jar文件全部都导入了。  然后我看了 GitHub上的(https://github.com/Baidu-AIP/java-sdk/blob/master/src/main/java/com/baidu/aip/speech/AipSpeech.java)源代码,发现就是以下这句有问题:
另外我在调试过程中,调用了几次,然后我在百度控制台上看见是调用成功了,但是每次报错都是相同的原因!!
【求助】请大家帮我看看呀!! 给我提提解决思路也好呀 !
收藏
点赞
1
个赞
共6条回复 最后由用户已被禁言回复于2022-04
#7用户已被禁言回复于2018-06
#5 来个名字2333回复
这个问题已经解决  应该是【jar包冲突了】具体怎么冲突,为什么冲突,还不知道,但是报错解决了。 我的项目是既需要语音识别也需要语音合成,我先完成了语音识别的部分,然后加入语音合成功能。 做语音识别部分,我加入了以下四个关于语音识别的包,然后为了加入语音合成功能,我把下面底下的三个jar包(保留aip-core-1.3.8)给删除了,然后加入了语音合成需要的三个包,就出现了之前说的错误。 [图片] 因为整个过程,我是按照百度给的官方文档在做,我感觉没啥错,之后就是自己能想到的方法都试了。但是仍然报错。在问了大神小帅之后,我开始了重新的尝试,就是我新建项目,重新弄一下,发现并没有错。看来是我之前的项目的问题,于是我就开始清理jar包,然后我把aip-core-1.3.8 这个包删除之后就不报错了,其实之前我也把这个包尝试过删除,但是我只是从buildpath中移除,没有从磁盘上删除。【感谢大家】
展开

现在的情况 基本用maven搭建的很多了。还是单独下载jar引入的很少了。maven引入会自动加载依赖的jar。点击就会自动下载源代码。很方便的。

1
#6用户已被禁言回复于2018-06

我这里用最新的SDK测试合成是没有问题的。成功调用。然后是你代码处理报错。并不会被统计的哦。除非是接口合成的数据有问题才会统计失败哦。

  • 示例代码
import org.json.JSONObject;

import com.baidu.aip.speech.AipSpeech;
import com.baidu.aip.speech.TtsResponse;
import com.baidu.aip.util.Util;

public class SDKTTSSample {
	public static void main(String[] args) {
		AipSpeech aipSpeech = new AipSpeech("", "", "");
		TtsResponse response = aipSpeech.synthesis("你好", "zh", 1, null);
		byte[] data = response.getData();
		JSONObject object = response.getResult();
		if(data!=null){
			try {
				Util.writeBytesToFileSystem(data, "output.mp3");
			} catch (Exception e) {
				System.out.println(e.getMessage());
			}
		}
	}
}

 

我新建项目 JDK1.8 使用maven搭建 引入aip最新版本。然后会自动依赖2个jar 

1
#5来个名字2333回复于2018-06

这个问题已经解决  应该是【jar包冲突了】具体怎么冲突,为什么冲突,还不知道,但是报错解决了。

我的项目是既需要语音识别也需要语音合成,我先完成了语音识别的部分,然后加入语音合成功能。

做语音识别部分,我加入了以下四个关于语音识别的包,然后为了加入语音合成功能,我把下面底下的三个jar包(保留aip-core-1.3.8)给删除了,然后加入了语音合成需要的三个包,就出现了之前说的错误。

因为整个过程,我是按照百度给的官方文档在做,我感觉没啥错,之后就是自己能想到的方法都试了。但是仍然报错。在问了大神小帅之后,我开始了重新的尝试,就是我新建项目,重新弄一下,发现并没有错。看来是我之前的项目的问题,于是我就开始清理jar包,然后我把aip-core-1.3.8 这个包删除之后就不报错了,其实之前我也把这个包尝试过删除,但是我只是从buildpath中移除,没有从磁盘上删除。【感谢大家】

0
#4来个名字2333回复于2018-06

你好~ 没想到你这么快就回复了 我详细说一下我

①我不是maven项目,我用你给的链接里面的4.3.2 版本试了一下 还是有相同问题。

②我的SDK的版本是4.1.1 另外两个依赖的jar版本如下,都是直接从平台上( http://ai.baidu.com/sdk )直接下载的(三个jar打包好的)

③好像有人遇到了和我相同的问题 这个链接    http://ai.baidu.com/forum/topic/show/864131     里面第二个回复  #3  (后面有个是我写的)

④我的具体做法是:

0
#2用户已被禁言回复于2018-06

你使用的sdk是最新版本的吗?你并不是maven项目?

1
TOP
切换版块