python3.6引用百度aip报错
wu9sang 发布于2018-06 浏览:6638 回复:14
0
收藏

安装了baidu-aip 2.2.5.0引用库报错如下,求解决办法

Traceback (most recent call last):
File "D:/Python/FaceTest/face-baidu.py", line 8, in
from aip import AipFace
File "C:\Program Files\Python36\lib\site-packages\aip\__init__.py", line 6, in
from .ocr import AipOcr
File "C:\Program Files\Python36\lib\site-packages\aip\ocr.py", line 12, in
from .base import AipBase
File "C:\Program Files\Python36\lib\site-packages\aip\base.py", line 14, in
requests.packages.urllib3.disable_warnings()
AttributeError: module 'pip' has no attribute 'disable_warnings'

收藏
点赞
0
个赞
共14条回复 最后由wos兲回复于2019-04
#15wos兲回复于2019-04

后来到这里的朋友,只要把报错的库全用pip更新就ok了  

1
#14131******11回复于2018-12

请问一下,这个问题解决了吗?我也遇到同样的问题

0
#13meneye回复于2018-11

碰到同样的问题,已解决,分享一下,requests库的问题,把requests卸载重新安装新版本就OK了

1
#12回眸醉—殇回复于2018-07

install baidu-aip我这边就不报错了。需要导入aip和baidu-aip两个包

1
#11回眸醉—殇回复于2018-07

我和你一样,aip导入简单,aipface就不行了。请问楼主大大,如何解决的啊?

0
#10用户已被禁言回复于2018-06
#9 wu9sang回复
都没有其他代码,就引用包直接就报错 [图片]

libraries里面有百度的sdk吗?

1
#9wu9sang回复于2018-06
#8 用户已被禁言回复
方便截个图不

都没有其他代码,就引用包直接就报错

0
#8用户已被禁言回复于2018-06
#7 wu9sang回复
有加入到项目里,奇怪怎么弄都不行,卸载了重装也是同样的错误。。。

方便截个图不

1
#7wu9sang回复于2018-06
#6 用户已被禁言回复
我看了。我MyEclipse安装的是Python 3 不知道 3和3.6差距大不大 你安装了sdk 有加入到项目里面吗?
展开

有加入到项目里,奇怪怎么弄都不行,卸载了重装也是同样的错误。。。

0
#6用户已被禁言回复于2018-06
#5 wu9sang回复
好的,非常感谢!

我看了。我MyEclipse安装的是Python 3 不知道 3和3.6差距大不大

你安装了sdk 有加入到项目里面吗?

1
#5wu9sang回复于2018-06
#4 用户已被禁言回复
那就不清楚了。我是Java。用myeclipse安装的python插件。安装百度sdk  调用并没有任何问题。明天我看看我开发工具的python版本。
展开

好的,非常感谢!

0
#4用户已被禁言回复于2018-06
#3 wu9sang回复
baidu-aip 2.2.5.0已经是最新的SDK了,引用库就报错了
展开

那就不清楚了。我是Java。用myeclipse安装的python插件。安装百度sdk  调用并没有任何问题。明天我看看我开发工具的python版本。

1
#3wu9sang回复于2018-06
#2 用户已被禁言回复
这个错误是sdk导致的吗?你更新成最新的呢?

baidu-aip 2.2.5.0已经是最新的SDK了,引用库就报错了

0
#2用户已被禁言回复于2018-06

这个错误是sdk导致的吗?你更新成最新的呢?

1
TOP
切换版块