win10家庭版安装paddlepaddle失败
龍宇天下我做主 发布于2018-12-30 13:03 浏览:492 回复:21
0
收藏

软件学院在校学生,小白一枚,遇到难题,无力解决,恳求大佬,抬我一手

交代一下环境,win10家庭版,Python 3.6.7,pip 18.1

根据官网的提示,在命令行下运行 pip install paddlepaddle 和 pip3 install paddlepaddle

均提示无法找到合适版本,如下图

问题已困扰我一天。。恳请各位大佬帮帮忙。。在线等

收藏
点赞
0
个赞
共21条回复 最后由dsadsa429回复于2019-05-04 10:21
#22dsadsa429回复于2019-05-04 10:21:54
#12 qqqw151回复
你可以这样 创建运行环境,输入指令: conda create -n paddle python=2.7 输入“y“和回车后开始安装。 激活并进入环境,使后续指令在激活的环境中生效,输入指令: conda activate paddle 升级pip python -m pip install --upgrade pip  安装paddle pip install paddlepaddle  
展开

conda没有这个命令怎么办

0
#21dsadsa429回复于2019-05-04 10:15:28
#9 龍宇天下我做主回复
问题已经 解决了,装了anaconda,可以用了。感谢大佬的帮助,希望对其他人也能有所帮助吧。 最后只想说 软件工程可真是一门玄学;
展开

楼主能帮我看看吗

 

0
#18goJhou回复于2019-01-02 09:19:37
#15 qqqw151回复
这个和系统版本没关系的

系统版本会阉割很多重要的服务。最好还是按照手册来部署

0
#17qqqw151回复于2019-01-01 21:47:49
#14 天子骄子fly回复
官方说支持Windows 10的专业版和企业,这个还不知到支不支持?

反正这个也是创建一个conda环境,到时候不要了还可以删掉

0
#16qqqw151回复于2019-01-01 21:47:15
#14 天子骄子fly回复
官方说支持Windows 10的专业版和企业,这个还不知到支不支持?

你照着我给的命令装一遍试试

 

0
#15qqqw151回复于2019-01-01 21:46:46
#14 天子骄子fly回复
官方说支持Windows 10的专业版和企业,这个还不知到支不支持?

这个和系统版本没关系的

0
#14天子骄子fly回复于2019-01-01 17:39:19

官方说支持Windows 10的专业版和企业,这个还不知到支不支持?

0
#13qqqw151回复于2018-12-31 16:27:53
#5 龍宇天下我做主回复
[图片] 试了阿里云,豆瓣,清华三个镜像源。。还是这个问题

有问题再找我

0
#12qqqw151回复于2018-12-31 16:27:04

你可以这样

创建运行环境,输入指令:
conda create -n paddle python=2.7

输入“y“和回车后开始安装。

激活并进入环境,使后续指令在激活的环境中生效,输入指令:

conda activate paddle

升级pip

python -m pip install --upgrade pip 

安装paddle

pip install paddlepaddle

 

0
#11qqqw151回复于2018-12-31 16:23:35

我觉得是你的python版本不对,你直接安装conda2,而且你这种方法安装的是CPU版本的,这个要注意一下

0
#10goJhou回复于2018-12-30 17:11:39
#9 龍宇天下我做主回复
问题已经 解决了,装了anaconda,可以用了。感谢大佬的帮助,希望对其他人也能有所帮助吧。 最后只想说 软件工程可真是一门玄学;
展开

成功安装不一定能成功运行呢。还是以官方要求的最低标准为准吧

0
#9龍宇天下我做主回复于2018-12-30 15:47:11

问题已经 解决了,装了anaconda,可以用了。感谢大佬的帮助,希望对其他人也能有所帮助吧。

最后只想说

软件工程可真是一门玄学;

0
#8龍宇天下我做主回复于2018-12-30 15:45:41
#7 goJhou回复
Windows 10 专业版/企业版

pip是18.1的,win10 确实是家庭版。。不过一堆同学的家庭版非常顺利的就装了。。

0
#7goJhou回复于2018-12-30 14:52:36

Windows 10 专业版/企业版

0
#6goJhou回复于2018-12-30 14:52:13

pip3>=9.0.1

0
#5龍宇天下我做主回复于2018-12-30 13:37:18
#2 goJhou回复
把pip镜像改一改。你用的这镜像没paddle

试了阿里云,豆瓣,清华三个镜像源。。还是这个问题

0
#4龍宇天下我做主回复于2018-12-30 13:23:39
#2 goJhou回复
把pip镜像改一改。你用的这镜像没paddle

是把镜像源改为国内么

0
#3龍宇天下我做主回复于2018-12-30 13:17:24
#2 goJhou回复
把pip镜像改一改。你用的这镜像没paddle

大佬能说的详细一点么。。这词我听过。。但是还不懂怎么用

0
#2goJhou回复于2018-12-30 13:09:43

把pip镜像改一改。你用的这镜像没paddle

0
TOP
切换版块