安装DeepASR模块出错
古月剑蘅 发布于2019-01-08 17:15 浏览:725 回复:5
0
收藏

各位大佬,我在安装DeepASR模块的时候出现下面的错误,请问该怎么解决啊?

running build_ext
building 'post_latgen_faster_mapped' extension
g++ -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Ipybind11/include -I. -I/home/hhj/GradDesi/kaldi/src -I/home/hhj/GradDesi/kaldi/tools/openfst/src/include -IThreadPool -I/usr/include/python2.7 -c pybind.cc -o build/temp.linux-x86_64-2.7/pybind.o -std=c++11 -fopenmp -Wno-sign-compare -Wno-unused-variable -Wno-unused-local-typedefs -Wno-unused-but-set-variable -Wno-deprecated-declarations -Wno-unused-function
g++ -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Ipybind11/include -I. -I/home/hhj/GradDesi/kaldi/src -I/home/hhj/GradDesi/kaldi/tools/openfst/src/include -IThreadPool -I/usr/include/python2.7 -c post_latgen_faster_mapped.cc -o build/temp.linux-x86_64-2.7/post_latgen_faster_mapped.o -std=c++11 -fopenmp -Wno-sign-compare -Wno-unused-variable -Wno-unused-local-typedefs -Wno-unused-but-set-variable -Wno-deprecated-declarations -Wno-unused-function
g++ -pthread -shared -Wl,-z,relro build/temp.linux-x86_64-2.7/pybind.o build/temp.linux-x86_64-2.7/post_latgen_faster_mapped.o -L/home/hhj/GradDesi/kaldi/tools/openfst/lib -L/home/hhj/GradDesi/kaldi/src/base -L/home/hhj/GradDesi/kaldi/src/matrix -L/home/hhj/GradDesi/kaldi/src/util -L/home/hhj/GradDesi/kaldi/src/tree -L/home/hhj/GradDesi/kaldi/src/hmm -L/home/hhj/GradDesi/kaldi/src/fstext -L/home/hhj/GradDesi/kaldi/src/decoder -L/home/hhj/GradDesi/kaldi/src/lat -L/usr/lib64 -Wl,-R/home/hhj/GradDesi/kaldi/tools/openfst/lib -Wl,-R/home/hhj/GradDesi/kaldi/src/base -Wl,-R/home/hhj/GradDesi/kaldi/src/matrix -Wl,-R/home/hhj/GradDesi/kaldi/src/util -Wl,-R/home/hhj/GradDesi/kaldi/src/tree -Wl,-R/home/hhj/GradDesi/kaldi/src/hmm -Wl,-R/home/hhj/GradDesi/kaldi/src/fstext -Wl,-R/home/hhj/GradDesi/kaldi/src/decoder -Wl,-R/home/hhj/GradDesi/kaldi/src/lat -lfst -lkaldi-base -lkaldi-util -lkaldi-matrix -lkaldi-tree -lkaldi-hmm -lkaldi-fstext -lkaldi-decoder -lkaldi-lat -lpython2.7 -o /home/hhj/GradDesi/models/fluid/DeepASR/decoder/post_latgen_faster_mapped.so
/usr/bin/ld: cannot find -lkaldi-base
/usr/bin/ld: cannot find -lkaldi-util
/usr/bin/ld: cannot find -lkaldi-matrix
/usr/bin/ld: cannot find -lkaldi-tree
/usr/bin/ld: cannot find -lkaldi-hmm
/usr/bin/ld: cannot find -lkaldi-fstext
/usr/bin/ld: cannot find -lkaldi-decoder
/usr/bin/ld: cannot find -lkaldi-lat
collect2: error: ld returned 1 exit status
error: command 'g++' failed with exit status 1
收藏
点赞
0
个赞
共5条回复 最后由开心的智障玉回复于2020-05-26 19:26
#6开心的智障玉回复于2020-05-26 19:26:43

您好,我在使用百度DeepASR的时候遇到了下面这个问题,不知是否是和您一样的情况,请问,您的building是如何启动的呢?非常感谢!

ModuleNotFoundError: No module named 'post_latgen_faster_mapped'
0
#5古月剑蘅回复于2019-01-19 20:52:49
#4 busyboxs回复
解决了就好,主要是没人做过的话也不知道该如何去解决,还是得靠自己呀

是的

0
#4busyboxs回复于2019-01-09 20:40:47
#3 古月剑蘅回复
是kaldi安装的有问题,已解决

解决了就好,主要是没人做过的话也不知道该如何去解决,还是得靠自己呀

0
#3古月剑蘅回复于2019-01-09 17:14:45

是kaldi安装的有问题,已解决

0
#2古月剑蘅回复于2019-01-09 13:56:40
  1. 有人吗?
0
TOP
切换版块