PaddleDetection最近使用不了
GGGGFFF1 发布于2020-11 浏览:1379 回复:4
0
收藏

在最近使用ppdet的时候,老是会报错,module 'paddle' has no attribute 'enable_static' 错

上网搜索了下是paddle2.0 版要加上paddle.enable_static()这句话才能静态图跑,然后我看了看我的ppdet里面的确有这句话的,因此应该是release0.4吧,然后我项目更新到paddle2.0 rc 仍然报错: module 'paddle' has no attribute 'enable_static'

更新到最新的paddle了,而且应该是paddle2.0的功能呀,为什么又说没有这个函数呢?

然后我用1.8.4运行一下,把ppdet的paddle.enable_static()这句话给去掉,然后又有另一个报错,说我版本不够高级,某些函数不存在:

401-WARNING: paddle.fluid.layers.matrix_nms OP not found, maybe a newer version of paddle is required.

于是我不用最近版本的paddledetection

!git clone https://gitee.com/paddlepaddle/PaddleDetection.git --branch release/0.2

用回0.2版本的ppdet,然后用1.8.4的paddle

最后还是报错,所以可能是AIstudio默认开启动态图

那我们在ppdet的train.py 的from   xxx   import xxx 的后面加上这一句就好了

import sys
sys.path.append("/home/aistudio/PaddleDetection")
import paddle
paddle.enable_static()

 
收藏
点赞
0
个赞
共4条回复 最后由周小鱼whoyou回复于2020-11
#5周小鱼whoyou回复于2020-11
#3 GGGGFFF1回复
更新一下,刚刚重新登录了AIStudio,还是1.8.4 的paddle,但是又报错module 'paddle' has no attribute 'enable_static' 因此可以把  paddle.enable_static()这句删掉 所以应该加上的代码是 import sys sys.path.append("/home/aistudio/PaddleDetection") 至于选哪一种来加,看报错是怎样的,亲测可以使用  
展开

多谢分享

0
#4七年期限回复于2020-11
#3 GGGGFFF1回复
更新一下,刚刚重新登录了AIStudio,还是1.8.4 的paddle,但是又报错module 'paddle' has no attribute 'enable_static' 因此可以把  paddle.enable_static()这句删掉 所以应该加上的代码是 import sys sys.path.append("/home/aistudio/PaddleDetection") 至于选哪一种来加,看报错是怎样的,亲测可以使用  
展开

顶一下

0
#3GGGGFFF1回复于2020-11

更新一下,刚刚重新登录了AIStudio,还是1.8.4 的paddle,但是又报错module 'paddle' has no attribute 'enable_static'

因此可以把  paddle.enable_static()这句删掉

所以应该加上的代码是

import sys
sys.path.append("/home/aistudio/PaddleDetection")
至于选哪一种来加,看报错是怎样的,亲测可以使用

 
0
#2七年期限回复于2020-11

0
TOP
切换版块