python3.6引用百度aip报错
wu9sang 发布于2018-06-11 15:23 浏览:115 回复:9
0
收藏

安装了baidu-aip 2.2.5.0引用库报错如下,求解决办法

Traceback (most recent call last):
File "D:/Python/FaceTest/face-baidu.py", line 8, in <module>
from aip import AipFace
File "C:\Program Files\Python36\lib\site-packages\aip\__init__.py", line 6, in <module>
from .ocr import AipOcr
File "C:\Program Files\Python36\lib\site-packages\aip\ocr.py", line 12, in <module>
from .base import AipBase
File "C:\Program Files\Python36\lib\site-packages\aip\base.py", line 14, in <module>
requests.packages.urllib3.disable_warnings()
AttributeError: module 'pip' has no attribute 'disable_warnings'

收藏
点赞
0
个赞
共9条回复 最后由756665228回复于2018-06-13 08:49
#2756665228回复于2018-06-11

这个错误是sdk导致的吗?你更新成最新的呢?

1
#3wu9sang回复于2018-06-11
#2 756665228回复
这个错误是sdk导致的吗?你更新成最新的呢?

baidu-aip 2.2.5.0已经是最新的SDK了,引用库就报错了

0
#4756665228回复于2018-06-11
#3 wu9sang回复
baidu-aip 2.2.5.0已经是最新的SDK了,引用库就报错了
展开

那就不清楚了。我是Java。用myeclipse安装的python插件。安装百度sdk  调用并没有任何问题。明天我看看我开发工具的python版本。

1
#5wu9sang回复于2018-06-12
#4 756665228回复
那就不清楚了。我是Java。用myeclipse安装的python插件。安装百度sdk  调用并没有任何问题。明天我看看我开发工具的python版本。
展开

好的,非常感谢!

0
#6756665228回复于2018-06-12
#5 wu9sang回复
好的,非常感谢!

我看了。我MyEclipse安装的是Python 3 不知道 3和3.6差距大不大

你安装了sdk 有加入到项目里面吗?

1
#7wu9sang回复于2018-06-12
#6 756665228回复
我看了。我MyEclipse安装的是Python 3 不知道 3和3.6差距大不大 你安装了sdk 有加入到项目里面吗?
展开

有加入到项目里,奇怪怎么弄都不行,卸载了重装也是同样的错误。。。

0
#8756665228回复于2018-06-12
#7 wu9sang回复
有加入到项目里,奇怪怎么弄都不行,卸载了重装也是同样的错误。。。

方便截个图不

1
#9wu9sang回复于2018-06-13
#8 756665228回复
方便截个图不

都没有其他代码,就引用包直接就报错

0
#10756665228回复于2018-06-13
#9 wu9sang回复
都没有其他代码,就引用包直接就报错 [图片]

libraries里面有百度的sdk吗?

1
TOP
切换版块